User created slidestyle doesn't include follow filters

Having problems? Have a solution? Let us know what your dilemma is with ProShow Producer. Please limit the topics to software problems, not "How To's"
Active Member
Posts: 42
Joined: Sat May 18, 2013 3:35 am
Location: England

User created slidestyle doesn't include follow filters

Postby nsd3 » Wed Mar 22, 2023 10:38 am

Does anyone have the same issue whereby Proshow Producer V9 does not save any Follow Filter settings applied to image layers?

I add two images to a slide, and add motion to the image on layer 1
Selecting layer 2, go to Slide Options>Filters (Tab)> Follow Filter
Set the Target as layer 1
Enable Position and set follow with offset values to -10. the values can be anything you like, this is just by way of example.

When you preview play the slide, the image on layer 2 will follow the movement of the image on layer 1 with the offset values you specify. That's the behaviour I'd expect. However if I save the slide as a new user created user slide style, and apply it to an new slide with two images, the target set in layer 2 (which refers to layer 1) is blank. The slide no longer works. All other slide attributes appear to be carried into the slide style, it's just the target layer that's lost. Anyone else experiencing this?

regards,

Steve

.
User avatar
Posts: 4553
Joined: Sat Jul 15, 2006 10:07 am
Location: Israel

Re: User created slidestyle doesn't include follow filters

Postby cherub » Thu Mar 23, 2023 12:55 am

Hi Steve,
Was this style made by you from scratch, or did you take an already existing style, made some changes and then saved it as a new style?
If your style is based on another style, there is a possibility that your new style is still "linked" to that previous style (by this, I mean that the 2nd layer is trying to follow something that isn't there anymore).
Try to remake your style from scratch, without copying layers from slide to slide.

Active Member
Posts: 42
Joined: Sat May 18, 2013 3:35 am
Location: England

Re: User created slidestyle doesn't include follow filters

Postby nsd3 » Thu Mar 23, 2023 8:25 am

Hi Mona,
The style was made from scratch. The actual style I want to work is a lot more complex than the example I gave. I just gave the simplest example I could think of that showed the issue of the layers not following correctly. I'm more curious if this is a bug or it's something unique to my instance of PSP 9.

Regards,

Steve

.
User avatar
Posts: 4553
Joined: Sat Jul 15, 2006 10:07 am
Location: Israel

Re: User created slidestyle doesn't include follow filters

Postby cherub » Thu Mar 23, 2023 6:24 pm

Sorry Steve,
I don't have any other answer. I don't use ProShow anymore, so I wouldn't know of any bugs.

Active Member
Posts: 42
Joined: Sat May 18, 2013 3:35 am
Location: England

Re: User created slidestyle doesn't include follow filters

Postby nsd3 » Fri Mar 24, 2023 4:29 am

Hi Mona,

I finally managed to get my slide style to work, but it took some effort.
First, I had to recreate the slide style again from scratch in a brand new totally empty slide show. When I created the style it still didn't work when applied to a new slide, but at least this time the slide style had the follow filter targets included. Unfortunately, the layers referenced their wrong target layer.

Exporting the slide style to a PXS file allowed me to have a look at what was going on internally. Using a text editor, I delved inside and found the offending command lines which look something like this:

cell[0].images[1].follow.targetObjectId=1

It gets slightly confusing here, as the reference to “.images[1]” refers to the referencing layer number+1. In other words “.images[1]” refers to layer 2, “.images[4]” refers to layer 5 and so forth.

The second part of the solution is the “.targetObjectID”. This refers to the layer you want to target. This time the number following “.targetObjectID” refers directly to the layer you want to target. So “.targetObjectID=3” does mean layer 3. It's this part of the command that I've found has the wrong references.

Putting it all together with a couple of examples…

cell[0].images[4].follow.targetObjectId=2 Means for layer 5, the target is layer 2.
cell[0].images[6].follow.targetObjectId=6 Means for layer 7, the target is layer 6.

All I had to do was change the offending lines to point to the correct layers, delete the slide style from PSP9 then add the PXS file back in again through the FX window. Now everything works.

As an aside Mona, you say you don’t use PSP anymore. What’s you’re preferred slide show replacement?

.
User avatar
Posts: 4553
Joined: Sat Jul 15, 2006 10:07 am
Location: Israel

Re: User created slidestyle doesn't include follow filters

Postby cherub » Fri Mar 24, 2023 8:16 pm

Steve,
Glad you've solved your problem, as complicated as it sounds :-)
As to your aside question: I don't have any other preferred slide show program, for the simple reason that I don't make shows anymore.
I travel a lot, and have thousands of pictures, but I don't feel the need to put them in any show.
I simply upload my pictures to Google Photos/Albums and share the link with friends.
Sometimes I pick a few pictures for my personal FB page.
:D :D :D

Active Member
Posts: 42
Joined: Sat May 18, 2013 3:35 am
Location: England

Re: User created slidestyle doesn't include follow filters

Postby nsd3 » Sun Mar 26, 2023 4:49 am

Hi Mona,

Like you I like to travel, and similarly I too have thousands of pictures. I still create slide shows mainly as the most convenient way to just revisit a place and watch on a TV. I don't share with anyone, neither do I upload images, everything is kept locally in the original image format, to maintain the highest image quality. I make copies if I need them for other purposes. I find it easier and much faster to work that way. Of course that's just my preference. I really enjoy photography, it's my second passion after music. Anyway, I'll stick with PSP9 for now, as I still haven't seen anything out there that really interests me except the hugely expensive Photopia, but I find their product pricing utterly ridiculous. I'll keep an eye on the slide show creation market, but like I say, PSP is still a pretty hard act to beat.

Steve

.
Posts: 28
Joined: Sat Feb 01, 2020 9:30 am

Re: User created slidestyle doesn't include follow filters

Postby CindyE » Tue Mar 28, 2023 9:57 am

Hi Steve...I thought I would pass this info on to you in case you might be interested. If you have a facebook page, there is a great group that is very helpful, Proshow Producer Support.
https://www.facebook.com/groups/338829398351892
Hope this is OK to post here. The group has quite a few people that have joined, it was started after PSP site closed, and has a large following now. I also did not want to go to Photopia as I don't care for the subscriber fees. I mainly make shows for my own use to view photos or for my family.
Regards, Cindy Elmore

.
User avatar
Posts: 128
Joined: Tue Aug 02, 2016 8:36 am
Location: Urk Holland

Re: User created slidestyle doesn't include follow filters

Postby Riekelt » Sun Apr 02, 2023 12:31 am

cherub wrote:Steve,
Glad you've solved your problem, as complicated as it sounds :-)
As to your aside question: I don't have any other preferred slide show program, for the simple reason that I don't make shows anymore.
I travel a lot, and have thousands of pictures, but I don't feel the need to put them in any show.
I simply upload my pictures to Google Photos/Albums and share the link with friends.
Sometimes I pick a few pictures for my personal FB page.
:D :D :D


nice to here /read from you again Mona ( Cherub)
If you see your personal info :

Posts: 4552
Joined: 15 Jul 2006, 20:07
Location: Israel

I can well imagine your solution to show you many photos. Somehow show making has taken a back seat in 2023. Due to the advent of the mobile phone and putting together a show with two thumbs, the art of creating a truly unique piece of creativity has suddenly become less exciting. But I still want to say that I have appreciated your presence here on the forum and your input is always instructive. I hope you'll stop by as much as I did :)

greetings from Urk, Holland
Riekelt Koffeman

WIN10 PSP 9.0
MAC OSX Photoshop / Lightroom
Foto CANON 80D

.
User avatar
Posts: 4553
Joined: Sat Jul 15, 2006 10:07 am
Location: Israel

Re: User created slidestyle doesn't include follow filters

Postby cherub » Mon Apr 03, 2023 1:57 am

Hi Reikelt,
Thank you for your kind words.
I do try to stop by from time to time, though my interest in ProShow and shows in general, is far from what it was once.
All my best to all the forum members.

Active Member
Posts: 42
Joined: Sat May 18, 2013 3:35 am
Location: England

Re: User created slidestyle doesn't include follow filters

Postby nsd3 » Wed Apr 05, 2023 12:58 am

CindyE wrote:Hi Steve...I thought I would pass this info on to you in case you might be interested. If you have a facebook page, there is a great group that is very helpful, Proshow Producer Support.
https://www.facebook.com/groups/338829398351892
Hope this is OK to post here. The group has quite a few people that have joined, it was started after PSP site closed, and has a large following now. I also did not want to go to Photopia as I don't care for the subscriber fees. I mainly make shows for my own use to view photos or for my family.
Regards, Cindy Elmore


Hi Cindy, thanks for that. I do have a Facebook account, so I've requested to join the group.

Steve

Return to PSP - Troubleshooting

Who is online

Users browsing this forum: No registered users and 9 guests